ASP.NET CoreABP

  1. 概述

ABP 基于 ASP.NET Core 3.0 的新版测试版本框架发布一年多了。地址:https://abp.io/get-started

最近几天在测试安装 ABP CLI 工具的时候总是提示错误信息:npm ERR! code EINTEGRITY

原因可能是有些 npm 包文件没有下载安装完整。折腾几次后解决了,这里记录一下。

2. ABP CLI安装

安装 abp.io 官网提供的安装步骤如下:https://abp.io/get-started

2.1 安装 Cli 工具

执行命令:(需要首先安装 .Net Core,下载地址:http://dot.net)

dotnet tool install -g Volo.Abp.Cli

2.2 创建解决方案

执行命令:(需要首先安装 node.js)

abp new Acme.BookStore

在这一步安装 @abp/aspnetcore.mvc.ui.theme.basic 包时总是提示错误信息:npm ERR! code EINTEGRITY

2.3 错误解决

如果遇到上述错误,可以分别执行下面命令解决:

首先,全局更新 npm:

npm install --global npm

然后,校验 npm 缓存:

npm cache verify

最后,重新执行 2.2 创建解决方案命令。


最后更新时间:2019/8/24 16:19:58